Home > Networking > Cisco Nexus Basic Config

Cisco Nexus Basic Config

February 7, 2012

 Here are some basic configs for the Cisco Nexus platform. I just started managing Nexus switches and immediately I realized how quickly these switches can scale. You can have just a huge huge data center with tons of 10GB connectivity with basically the same core configs.

Hopefully there will be more blog entries regarding the Cisco Nexus as they are a really cool product.

A couple of things I noticed:
no more wr mem (you can create an alias command)
There isn’t fa0/1, gig0/1, tengig0/1, everything is eth0/1.

———————————————————

vPC - virtual Port-Channel. vPC is just like a regular port-channel, but can span across two different switches.

vPC domain - the domain is between two switches that share the vPC. You can configure switch priority within the domain. Like STP, 8192 and 16384 are common values, the lower the better. You also need to configure the peer-keepalive destination IP address.

——————————————————-

Step 1
Create the vPC domain. Once the vPC domain is created, all the port-channel control data is sent over the vPC domain link. This is why you must create the vPC relationship first.

vpc domain 1
role priority 8192
peer-keepalive destination 172.31.1.254 source 172.31.1.253 vrf vpc-keepalive
peer-gateway

interface port-channel1001
switchport
switchport mode trunk
vpc peer-link
spanning-tree port type network

interface Ethernet1/1
switchport
switchport mode trunk
channel-group 1001 mode active
no shutdown

interface Ethernet1/2
switchport
switchport mode trunk
channel-group 1001 mode active
no shutdown


Step 2
int port-channel 20
vpc 20

In the second step, you create your port-channels as normal, except for the vpc 20 command. The “vpc 20″ tells the port-channel that this is a part of a vPC.

In the Nexus platform, you have to enable features as you need them. This saves memory, performance, less running processes.

———————————————————–

Nexus 5000 switch is a pure Layer 2 switch. You will not find any int vlan commands on the switch. The 5K can manage the Nexus 2K switches, very much like a Cisco 3750 stack configuration. This feature is called Fabric Extenders (FEX).

You still need to create the vPC domain and associate the vPC peer link to another Nexus 5K.

fex 30
pinning max-links 1
description “N2K”

interface port-channel30
switchport mode fex-fabric
vpc 30
fex associate 30

interface Ethernet1/4
fex associate 30
switchport mode fex-fabric
channel-group 30


In port-channel 30, noticed the commands related to the FEX command.

interface Ethernet30/1/1
interface Ethernet30/1/2
interface Ethernet30/1/3

You’ll see Ethernet30 is really FEX 30 and 1/1 is the physical ports belonging to the Nexus 2K switch. In this configuration, you do not need to SSH into the 2K switch. You can assign switchport commands and assign VLANs via int Ethernet30/1/X

In addition, if you created FEX 31 for another 2K switch, then you would refer those interfaces as int Ethernet31.
About these ads
Categories: Networking
Follow

Get every new post delivered to your Inbox.

%d bloggers like this: